# Connect2id

**Canonical:** https://apis.io/providers/connect2id/  
**Website:** https://connect2id.com  
**APIs profiled:** 14

Connect2id is the maker of the Connect2id server, an OpenID Connect and OAuth 2.0 authorization server, and the open-source Nimbus OAuth 2.0 / OpenID Connect SDK and Nimbus JOSE+JWT libraries for Java.

## Kin Score — 17.9 / 100 (emerging)

Scored 2026-11-06 under rubric 0.27.0. Trend: falling (-7.5 from 25.4).

| Facet | Score |
|---|---|
| Discoverability | 62.5 |
| Contract Quality | 0.0 |
| Contract Governance | 0.0 |
| Operational Transparency | 10.5 |
| Developer Ergonomics | 40.5 |
| Access Clarity | 10.5 |

Regulatory layer — **Horizontal (data, software, accessibility, platform)**: 15.7 (matched via fallback).

## Agent readiness — 15.1 (agent-aware)

| Dimension | Value |
|---|---|
| Spec Presence | no |
| Agentic Access | no |
| Reversibility Documented | no |
| MCP Server | no |
| Auth Clarity | served |
| Idempotency | no |
| Error Semantics | no |
| OpenAPI Examples | no |
| Rate Limit Signal | no |
| Event Surface Described | no |
| Agent Skills | no |
| Well Known Catalog | no |
| Consent Identity | no |
| Agent Card | no |
| Dry Run Mode | no |
| Delegated Identity | served |
| Protected Resource Metadata | no |
| Dynamic Client Registration | yes |
| Agentic Commerce | no |
| Pagination Ratio | na |
| Operation Distinctiveness | na |
| MCP Tool Quality | na |

## Access

Unknown — onboarding: unknown, pricing: unknown, trial: no (confidence: low).

## APIs (14)

- **Connect2id Server Authorization API** — OAuth 2.0 / OpenID Connect authorization endpoint.
- **Connect2id Server Token API** — OAuth 2.0 token endpoint.
- **Connect2id Server UserInfo API** — OpenID Connect UserInfo endpoint.
- **Connect2id Server Client Registration API** — OAuth 2.0 dynamic client registration and management.
- **Connect2id Server Token Introspection API** — OAuth 2.0 token introspection (RFC 7662).
- **Connect2id Server Token Revocation API** — OAuth 2.0 token revocation (RFC 7009).
- **Connect2id Server Pushed Authorization Requests API** — PAR endpoint (RFC 9126).
- **Connect2id Server CIBA API** — Client-Initiated Backchannel Authentication.
- **Connect2id Server Discovery API** — OpenID Provider metadata.
- **Connect2id Server JWK Set API** — Public JSON Web Key set.
- **Connect2id Server Logout API** — OpenID Connect logout / end session.
- **Connect2id Server Check Session API** — OpenID Connect session management iframe.
- **Connect2id Server Federation Client Registration API** — OpenID Federation client registration.
- **Connect2id Server Federation Entity Configuration API** — OpenID Federation entity configuration.

## Security (2)

- **Connect2Id Authentication** — 2 schemes
- **Connect2Id Domain Security** — TLSv1.3 · DNSSEC · DMARC

## Tags

Company, OpenID Connect, OAuth, Identity, Authentication

---

Profiled by [API Evangelist](https://apievangelist.com) and published on [APIs.io](https://apis.io/providers/connect2id/). Scores are computed from the provider's own public artifacts under a published rubric.
