# Monitive OAuth API

**Canonical:** https://apis.io/apis/uptimemonitoring-com/uptimemonitoring-com-oauth-api/  
**Provider:** Monitive — https://apis.io/providers/uptimemonitoring-com/  
**Base URL:** https://api.uptimemonitoring.com  
**Documentation:** https://uptimemonitoring.com/api-reference/

Monitive OAuth API is one of 15 APIs that [Monitive](https://apis.io/providers/uptimemonitoring-com/) publishes on the [APIs.io](https://apis.io/) network, described by a machine-readable OpenAPI specification. This API exposes 6 JSON Schema definitions. Tagged areas include OAuth. The published artifact set on APIs.io includes an OpenAPI specification and 6 JSON Schemas.

The OAuth API from Monitive — 16 operation(s) for oauth.

## Operations (16)

| Method | Path | Summary |
|---|---|---|
| GET | `/oauth/github/login` | Start GitHub OAuth flow |
| GET | `/oauth/github/callback` | GitHub OAuth callback (sign-in or identity link) |
| POST | `/oauth/github/link` | Start a GitHub identity link |
| POST | `/oauth/exchange` | Exchange auth code for session token |
| POST | `/oauth/email/start` | Start email sign-in (link or code) |
| POST | `/oauth/email/verify` | Verify an email sign-in link or code |
| GET | `/oauth/google/login` | Start Google OAuth flow (sign-in) |
| POST | `/oauth/google/link` | Start a Google identity link |
| GET | `/oauth/google/callback` | Google OAuth callback (sign-in or identity link) |
| GET | `/.well-known/oauth-protected-resource/mcp` | Protected resource metadata for /mcp (RFC 9728) |
| GET | `/.well-known/oauth-authorization-server` | Authorization server metadata (RFC 8414) |
| POST | `/oauth2/register` | Dynamic client registration (RFC 7591) |
| GET | `/oauth2/authorize` | OAuth 2.1 authorization endpoint |
| POST | `/oauth2/token` | OAuth 2.1 token endpoint |
| POST | `/oauth2/revoke` | OAuth 2.1 token revocation (RFC 7009) |
| GET | `/oauth2/keys` | JSON Web Key Set |

## Machine-readable artifacts (7)

- **OpenAPI** — https://artifacts.apis.io/uptimemonitoring-com/openapi/uptimemonitoring-com-oauth-api-openapi.yml
- **JSONSchema** — https://artifacts.apis.io/uptimemonitoring-com/json-schema/uptimemonitoring-com-monitor-input-schema.json
- **JSONSchema** — https://artifacts.apis.io/uptimemonitoring-com/json-schema/uptimemonitoring-com-uptime-day-schema.json
- **JSONSchema** — https://artifacts.apis.io/uptimemonitoring-com/json-schema/uptimemonitoring-com-recipient-schema.json
- **JSONSchema** — https://artifacts.apis.io/uptimemonitoring-com/json-schema/uptimemonitoring-com-account-schema.json
- **JSONSchema** — https://artifacts.apis.io/uptimemonitoring-com/json-schema/uptimemonitoring-com-recipient-patch-schema.json
- **JSONSchema** — https://artifacts.apis.io/uptimemonitoring-com/json-schema/uptimemonitoring-com-monitor-recipients-schema.json

## Other Monitive APIs (12)

- [Monitive Account API](https://apis.io/apis/uptimemonitoring-com/uptimemonitoring-com-account-api/)
- [Monitive Admin API](https://apis.io/apis/uptimemonitoring-com/uptimemonitoring-com-admin-api/)
- [Monitive Announcements API](https://apis.io/apis/uptimemonitoring-com/uptimemonitoring-com-announcements-api/)
- [Monitive Email API](https://apis.io/apis/uptimemonitoring-com/uptimemonitoring-com-email-api/)
- [Monitive Events API](https://apis.io/apis/uptimemonitoring-com/uptimemonitoring-com-events-api/)
- [Monitive Feed API](https://apis.io/apis/uptimemonitoring-com/uptimemonitoring-com-feed-api/)
- [Monitive Feed.xml API](https://apis.io/apis/uptimemonitoring-com/uptimemonitoring-com-feed-xml-api/)
- [Monitive Incidents API](https://apis.io/apis/uptimemonitoring-com/uptimemonitoring-com-incidents-api/)
- [Monitive Keys API](https://apis.io/apis/uptimemonitoring-com/uptimemonitoring-com-keys-api/)
- [Monitive Monitors API](https://apis.io/apis/uptimemonitoring-com/uptimemonitoring-com-monitors-api/)
- [Monitive Public API](https://apis.io/apis/uptimemonitoring-com/uptimemonitoring-com-public-api/)
- [Monitive Push API](https://apis.io/apis/uptimemonitoring-com/uptimemonitoring-com-push-api/)

## Tags

OAuth

---

Profiled by [API Evangelist](https://apievangelist.com) and published on [APIs.io](https://apis.io/apis/uptimemonitoring-com/uptimemonitoring-com-oauth-api/). The API's provider profile, Kin Score and agent-readiness rating are at https://apis.io/providers/uptimemonitoring-com/.
