# Infinite Audience OAuth API

**Canonical:** https://apis.io/apis/infiniteaudience-ai/infiniteaudience-ai-oauth-api/  
**Provider:** Infinite Audience — https://apis.io/providers/infiniteaudience-ai/  
**Base URL:** https://api.infiniteaudience.ai  
**Documentation:** https://docs.infiniteaudience.ai/api/

Infinite Audience OAuth API is one of 18 APIs that [Infinite Audience](https://apis.io/providers/infiniteaudience-ai/) publishes on the [APIs.io](https://apis.io/) network, described by a machine-readable OpenAPI specification. This API exposes 6 JSON Schema definitions. Tagged areas include OAuth. The published artifact set on APIs.io includes an OpenAPI specification, API documentation, and 6 JSON Schemas.

OAuth 2.0 authorization server for confidential integrations and delegated REST, MCP, and A2A clients. Authenticate on behalf of one of your customers via the standard authorization-code flow with PKCE or the A2A device authorization flow, then use the resulting resource-bound access token.

## Operations (14)

| Method | Path | Summary |
|---|---|---|
| GET | `/v1/oauth/authorize` | Begin an OAuth 2.0 authorization request |
| POST | `/v1/oauth/token` | Exchange an authorization code, device code, or refresh token for an access… |
| POST | `/v1/oauth/device_authorization` | Begin an OAuth device authorization for an A2A client |
| POST | `/v1/oauth/revoke` | Revoke a token (RFC 7009) |
| POST | `/v1/oauth/register` | Register a public OAuth client (RFC 7591 fallback) |
| GET | `/.well-known/oauth-authorization-server` | OAuth 2.0 authorization server metadata (RFC 8414) |
| GET | `/.well-known/openid-configuration` | OpenID Connect discovery metadata |
| GET | `/v1/oauth/jwks` | Public OIDC ID-token signing keys |
| GET | `/v1/oauth/userinfo` | Get current person-bound OIDC identity |
| POST | `/v1/oauth/userinfo` | Get current person-bound OIDC identity |
| GET | `/.well-known/openai-apps-challenge` | OpenAI MCP host ownership challenge |
| GET | `/.well-known/oauth-protected-resource` | REST protected-resource metadata (RFC 9728) |
| GET | `/.well-known/oauth-protected-resource/mcp` | MCP protected-resource metadata (RFC 9728) |
| GET | `/.well-known/oauth-protected-resource/a2a` | A2A protected-resource metadata (RFC 9728) |

## Machine-readable artifacts (8)

- **OpenAPI** — https://raw.githubusercontent.com/api-evangelist/infiniteaudience-ai/refs/heads/main/openapi/infiniteaudience-ai-oauth-api-openapi.yml
- **Documentation** — https://docs.infiniteaudience.ai/
- **JSONSchema** — https://raw.githubusercontent.com/api-evangelist/infiniteaudience-ai/refs/heads/main/json-schema/infiniteaudience-ai-segment-object-schema.json
- **JSONSchema** — https://raw.githubusercontent.com/api-evangelist/infiniteaudience-ai/refs/heads/main/json-schema/infiniteaudience-ai-audience-object-schema.json
- **JSONSchema** — https://raw.githubusercontent.com/api-evangelist/infiniteaudience-ai/refs/heads/main/json-schema/infiniteaudience-ai-delivery-object-schema.json
- **JSONSchema** — https://raw.githubusercontent.com/api-evangelist/infiniteaudience-ai/refs/heads/main/json-schema/infiniteaudience-ai-file-match-job-schema.json
- **JSONSchema** — https://raw.githubusercontent.com/api-evangelist/infiniteaudience-ai/refs/heads/main/json-schema/infiniteaudience-ai-audience-refresh-result-schema.json
- **JSONSchema** — https://raw.githubusercontent.com/api-evangelist/infiniteaudience-ai/refs/heads/main/json-schema/infiniteaudience-ai-campaign-schema.json

## Other Infinite Audience APIs (12)

- [Infinite Audience MCP Server](https://apis.io/apis/infiniteaudience-ai/infinite-audience-mcp/)
- [Infinite Audience A2A API](https://apis.io/apis/infiniteaudience-ai/infiniteaudience-ai-a2a-api/)
- [Infinite Audience Account API](https://apis.io/apis/infiniteaudience-ai/infiniteaudience-ai-account-api/)
- [Infinite Audience Audiences API](https://apis.io/apis/infiniteaudience-ai/infiniteaudience-ai-audiences-api/)
- [Infinite Audience Auth API](https://apis.io/apis/infiniteaudience-ai/infiniteaudience-ai-auth-api/)
- [Infinite Audience Campaigns API](https://apis.io/apis/infiniteaudience-ai/infiniteaudience-ai-campaigns-api/)
- [Infinite Audience Deliveries API](https://apis.io/apis/infiniteaudience-ai/infiniteaudience-ai-deliveries-api/)
- [Infinite Audience Discovery API](https://apis.io/apis/infiniteaudience-ai/infiniteaudience-ai-discovery-api/)
- [Infinite Audience Enrichment API](https://apis.io/apis/infiniteaudience-ai/infiniteaudience-ai-enrichment-api/)
- [Infinite Audience Integrations API](https://apis.io/apis/infiniteaudience-ai/infiniteaudience-ai-integrations-api/)
- [Infinite Audience MCP API](https://apis.io/apis/infiniteaudience-ai/infiniteaudience-ai-mcp-api/)
- [Infinite Audience Partnerships API](https://apis.io/apis/infiniteaudience-ai/infiniteaudience-ai-partnerships-api/)

## Tags

OAuth

---

Profiled by [API Evangelist](https://apievangelist.com) and published on [APIs.io](https://apis.io/apis/infiniteaudience-ai/infiniteaudience-ai-oauth-api/). The API's provider profile, Kin Score and agent-readiness rating are at https://apis.io/providers/infiniteaudience-ai/.
