# HEDGR OAuth discovery API

**Canonical:** https://apis.io/apis/hedgr-app/hedgr-app-oauth-discovery-api/  
**Provider:** HEDGR — https://apis.io/providers/hedgr-app/  
**Base URL:** https://hedgr.app  
**Documentation:** https://hedgr.app/developer-docs

HEDGR OAuth discovery API is one of 5 APIs that [HEDGR](https://apis.io/providers/hedgr-app/) publishes on the [APIs.io](https://apis.io/) network, described by a machine-readable OpenAPI specification. This API exposes 6 JSON Schema definitions. Tagged areas include OAuth Discovery. The published artifact set on APIs.io includes an OpenAPI specification and 6 JSON Schemas.

RFC 8414 / RFC 9728 metadata used to authenticate against the MCP endpoint.

## Operations (3)

| Method | Path | Summary |
|---|---|---|
| GET | `/.well-known/oauth-protected-resource` | RFC 9728 protected-resource metadata for the MCP endpoint |
| GET | `/.well-known/oauth-authorization-server` | RFC 8414 authorization-server metadata for the MCP OAuth flow |
| GET | `/.well-known/api-catalog` | RFC 9727 API catalog |

## Machine-readable artifacts (7)

- **OpenAPI** — https://artifacts.apis.io/hedgr-app/openapi/hedgr-app-oauth-discovery-api-openapi.yml
- **JSONSchema** — https://artifacts.apis.io/hedgr-app/json-schema/hedgr-app-mcp-discovery-schema.json
- **JSONSchema** — https://artifacts.apis.io/hedgr-app/json-schema/hedgr-app-mcp-server-card-schema.json
- **JSONSchema** — https://artifacts.apis.io/hedgr-app/json-schema/hedgr-app-api-catalog-schema.json
- **JSONSchema** — https://artifacts.apis.io/hedgr-app/json-schema/hedgr-app-json-rpc-request-schema.json
- **JSONSchema** — https://artifacts.apis.io/hedgr-app/json-schema/hedgr-app-authorization-server-metadata-schema.json
- **JSONSchema** — https://artifacts.apis.io/hedgr-app/json-schema/hedgr-app-protected-resource-metadata-schema.json

## Other HEDGR APIs (4)

- [HEDGR Health API](https://apis.io/apis/hedgr-app/hedgr-app-health-api/)
- [HEDGR MCP API](https://apis.io/apis/hedgr-app/hedgr-app-mcp-api/)
- [HEDGR Partner API](https://apis.io/apis/hedgr-app/hedgr-app-partner-api-api/)
- [HEDGR Rates API](https://apis.io/apis/hedgr-app/hedgr-app-rates-api/)

## Tags

OAuth Discovery

---

Profiled by [API Evangelist](https://apievangelist.com) and published on [APIs.io](https://apis.io/apis/hedgr-app/hedgr-app-oauth-discovery-api/). The API's provider profile, Kin Score and agent-readiness rating are at https://apis.io/providers/hedgr-app/.
