# Creavily OAuth API

**Canonical:** https://apis.io/apis/creavily/creavily-oauth-api/  
**Provider:** Creavily — https://apis.io/providers/creavily/  
**Base URL:** https://creavily-api.ecomwith.com  
**Documentation:** https://creavily.com/developers

Creavily OAuth API is one of 21 APIs that [Creavily](https://apis.io/providers/creavily/) publishes on the [APIs.io](https://apis.io/) network, described by a machine-readable OpenAPI specification. This API exposes 6 JSON Schema definitions. Tagged areas include OAuth. The published artifact set on APIs.io includes an OpenAPI specification and 6 JSON Schemas.

The OAuth API from Creavily — 4 operation(s) for oauth.

## Operations (5)

| Method | Path | Summary |
|---|---|---|
| GET | `/v1/oauth/authorize` | Preview a dashboard-user OAuth authorization request before consent |
| POST | `/v1/oauth/authorize` | Approve a dashboard-user OAuth authorization request and issue a short-lived… |
| GET | `/.well-known/oauth-authorization-server` | RFC 8414 authorization server metadata for MCP connectors (PKCE S256, resource… |
| POST | `/v1/oauth/register` | RFC 7591 Dynamic Client Registration for MCP connectors. |
| POST | `/v1/oauth/token` | Exchange an OAuth authorization code (with PKCE code_verifier and RFC 8707… |

## Machine-readable artifacts (7)

- **OpenAPI** — https://artifacts.apis.io/creavily/openapi/creavily-oauth-api-openapi.yml
- **JSONSchema** — https://artifacts.apis.io/creavily/json-schema/creavily-provider-capabilities-response-schema.json
- **JSONSchema** — https://artifacts.apis.io/creavily/json-schema/creavily-publishing-profile-save-request-schema.json
- **JSONSchema** — https://artifacts.apis.io/creavily/json-schema/creavily-channel-account-upsert-request-schema.json
- **JSONSchema** — https://artifacts.apis.io/creavily/json-schema/creavily-channel-account-patch-request-schema.json
- **JSONSchema** — https://artifacts.apis.io/creavily/json-schema/creavily-health-readiness-response-schema.json
- **JSONSchema** — https://artifacts.apis.io/creavily/json-schema/creavily-storage-readiness-response-schema.json

## Other Creavily APIs (12)

- [Creavily Admin API](https://apis.io/apis/creavily/creavily-admin-api/)
- [Creavily Agent API](https://apis.io/apis/creavily/creavily-agent-api/)
- [Creavily Analytics API](https://apis.io/apis/creavily/creavily-analytics-api/)
- [Creavily Assets API](https://apis.io/apis/creavily/creavily-assets-api/)
- [Creavily Auth API](https://apis.io/apis/creavily/creavily-auth-api/)
- [Creavily Automations API](https://apis.io/apis/creavily/creavily-automations-api/)
- [Creavily Billing API](https://apis.io/apis/creavily/creavily-billing-api/)
- [Creavily Blog API](https://apis.io/apis/creavily/creavily-blog-api/)
- [Creavily Brands API](https://apis.io/apis/creavily/creavily-brands-api/)
- [Creavily Bridges API](https://apis.io/apis/creavily/creavily-bridges-api/)
- [Creavily Channels API](https://apis.io/apis/creavily/creavily-channels-api/)
- [Creavily Developer API](https://apis.io/apis/creavily/creavily-developer-api/)

## Tags

OAuth

---

Profiled by [API Evangelist](https://apievangelist.com) and published on [APIs.io](https://apis.io/apis/creavily/creavily-oauth-api/). The API's provider profile, Kin Score and agent-readiness rating are at https://apis.io/providers/creavily/.
