# Anahana OAuth API

**Canonical:** https://apis.io/apis/anahana-com/anahana-com-oauth-api/  
**Provider:** Anahana — https://apis.io/providers/anahana-com/  
**Base URL:** https://www.anahana.com  
**Documentation:** https://www.anahana.com/openapi.json

Anahana OAuth API is one of 3 APIs that [Anahana](https://apis.io/providers/anahana-com/) publishes on the [APIs.io](https://apis.io/) network, described by a machine-readable OpenAPI specification. This API exposes 3 JSON Schema definitions. Tagged areas include OAuth. The published artifact set on APIs.io includes an OpenAPI specification and 3 JSON Schemas.

OAuth 2.1 registered tier. Optional — anonymous access to /mcp is fully supported.

## Operations (5)

| Method | Path | Summary |
|---|---|---|
| POST | `/mcp/register` | Dynamic client registration (RFC 7591) |
| GET | `/mcp/authorize` | Authorization endpoint (OAuth 2.1 authorization code + PKCE) |
| POST | `/mcp/token` | Token endpoint (also handles RFC 7009 revocation) |
| GET | `/.well-known/oauth-authorization-server` | Authorization server metadata (RFC 8414) |
| GET | `/.well-known/oauth-protected-resource` | Protected resource metadata (RFC 9728) |

## Machine-readable artifacts (4)

- **OpenAPI** — https://artifacts.apis.io/anahana-com/openapi/anahana-com-oauth-api-openapi.yml
- **JSONSchema** — https://artifacts.apis.io/anahana-com/json-schema/anahana-com-client-metadata-schema.json
- **JSONSchema** — https://artifacts.apis.io/anahana-com/json-schema/anahana-com-json-rpc-request-schema.json
- **JSONSchema** — https://artifacts.apis.io/anahana-com/json-schema/anahana-com-json-rpc-response-schema.json

## Other Anahana APIs (2)

- [Anahana Discovery API](https://apis.io/apis/anahana-com/anahana-com-discovery-api/)
- [Anahana MCP API](https://apis.io/apis/anahana-com/anahana-com-mcp-api/)

## Tags

OAuth

---

Profiled by [API Evangelist](https://apievangelist.com) and published on [APIs.io](https://apis.io/apis/anahana-com/anahana-com-oauth-api/). The API's provider profile, Kin Score and agent-readiness rating are at https://apis.io/providers/anahana-com/.
